[macports-base] branch master updated (96c46dffd -> b2519bb2c)

Joshua Root jmr at macports.org
Wed May 22 08:57:49 UTC 2024


Joshua Root (jmroot) pushed a change to branch master
in repository macports-base.

    from 96c46dffd Silence stderr from git commands
     new 6e2f45382 Implement MacPorts migration
     new 35bce54e2 registry2.0: Fix typo in snapshot code
     new f45c2c68f cregistry: Remove dead code
     new 3f83ad1f3 src: Support requested variants in migration code
     new 9dbef5e22 cregistry: Move variable to avoid magic constant
     new 314d57f42 cregistry/snapshot: Drop snapshot_port_id
     new 250b340d3 cregistry/snapshot: Add OOM error handling
     new 4bbcbdeff registry2.0/snapshotobj: Don't stringify integer
     new 4317a3210 macports/restore: Fix dependency calculation
     new f40f6556c macports/restore: Fix alternative providers
     new 687ec18a2 macports/restore: Add progress f/dep calculation
     new 0a659428a Add system note mechanism
     new 72478b1d3 macports/restore: Skip ports when deps failed
     new f77aca31d macports/snapshot: Add diff implementation
     new 49a98ea4e macports/restore: Use ===> as ui_prefix for restore operations
     new b2519bb2c macports/restore: Use snapshot::diff to display summary

The 16 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 doc/port-selfupdate.1.txt                         |  13 +-
 src/cregistry/Makefile.in                         |   2 +-
 src/cregistry/entry.h                             |   1 +
 src/cregistry/registry.c                          |   1 +
 src/cregistry/snapshot.c                          | 445 ++++++++++++++++
 src/cregistry/{file.h => snapshot.h}              |  52 +-
 src/cregistry/sql.c                               |  70 ++-
 src/macports1.0/Makefile.in                       |   3 +-
 src/macports1.0/macports.tcl                      |  86 +++-
 src/macports1.0/migrate.tcl                       | 171 +++++++
 src/macports1.0/restore.tcl                       | 586 ++++++++++++++++++++++
 src/macports1.0/selfupdate.tcl                    |   5 +-
 src/macports1.0/snapshot.tcl                      | 375 ++++++++++++++
 src/pextlib1.0/tracelib.c                         |   1 +
 src/port/port.tcl                                 |  73 ++-
 src/registry2.0/Makefile.in                       |   3 +-
 src/registry2.0/registry.c                        |   3 +
 src/registry2.0/registry.h                        |   1 +
 src/registry2.0/snapshot.c                        | 209 ++++++++
 src/registry2.0/{file.h => snapshot.h}            |  18 +-
 src/registry2.0/snapshotobj.c                     | 198 ++++++++
 src/registry2.0/{portgroupobj.h => snapshotobj.h} |  16 +-
 src/registry2.0/util.c                            |  72 +++
 src/registry2.0/util.h                            |   7 +
 24 files changed, 2357 insertions(+), 54 deletions(-)
 create mode 100644 src/cregistry/snapshot.c
 copy src/cregistry/{file.h => snapshot.h} (54%)
 create mode 100644 src/macports1.0/migrate.tcl
 create mode 100644 src/macports1.0/restore.tcl
 create mode 100644 src/macports1.0/snapshot.tcl
 create mode 100644 src/registry2.0/snapshot.c
 copy src/registry2.0/{file.h => snapshot.h} (83%)
 create mode 100644 src/registry2.0/snapshotobj.c
 copy src/registry2.0/{portgroupobj.h => snapshotobj.h} (82%)



More information about the macports-changes mailing list