p5-berkeleydb dyld problem

Cyril Bellot cbellot at sky.fr
Sun Jun 10 16:37:52 PDT 2007

Cyril Bellot a écrit :
> The new port builds correctly but the make test is still lost with
> library location. I first thaught it was because of db44 installed too
> on my system, but it's the same without it (tested on another system).

I tried the opposite method, and making p5-berkeleydb depending on db44
instead of db4 :

  depends_lib-append port:db44
  configure.env  BERKELEYDB_INCLUDE=${prefix}/include/db44 \

It works like this.

I think this is because db4 does not provide a libdb.dylib link (on the
opposite of db44)

Creating manually the link (/opt/local/lib/libdb.dylib ->
/opt/local/lib/libdb-4.3.dylib) and compiling again p5-berkeleydb solved
the problem.

I known db3 creates such a link. db44 (and db45...) create too in their
own subdirectories /opt/local/lib/db44 .  The case is different for db4
which puts its libraries right into /opt/local/lib.

Things may have to be reviewed on db4 port; some other dependent ports
may be broken too without this hack...

More information about the macports-dev mailing list