Proposed change to "Target" term in base ui_msg's

markd at markd at
Fri Sep 14 09:17:44 PDT 2007


Changing the ui_msgs in porttrace.tcl and portutil.tcl. from:

"Target $target returned/has a blah blah" to
"MacPorts Installation Phase $target returned/has a ...." or just
"Installation Phase $target returned/has a ....."


I think the term "target" in MacPorts user-level communication is
ambiguous and confusing.  It invites the question, "Target of what?"  At
the level of user-level messages at least, it seems "target" is more or
less synonymous with "phase", since "target phase" or just "phase" seems
to communicate the same thing more clearly.

But "phase" alone seems inadequate because that term invites the question
"What type of phase?" so I'd prefer the term "install phase", assuming
that it is ok to call all the MP phases generically "install phases", even
though technically install is a phase itself.  But that seems much better
than the way the old guide speaks of "build targets" generically, because
it seems more natural to call the MP phases "install phases" because
"building" has a more specific meaning and makes "build phases" seem
innaccurate (or at least confusing) as a term for MP phases.

What do you all think about this?  I want to harmonize the error messages
with the new guide and I've already expunged the term "target" for the
reasons stated above.

Here are the ui_msgs as they are now.

port1.0/porttrace.tcl:                  ui_warn "Target $target has an
undeclared dependency on $port"
port1.0/porttrace.tcl:                  ui_debug "Target $target has no
traceable dependency on $port"

port1.0/portutil.tcl:       ui_error "Target $name returned: $errstr"
port1.0/portutil.tcl:            ui_debug "$ident registered provides
'$target', a pre-existing procedure. Target override will not be provided"


More information about the macports-dev mailing list