[79008] branches/gsoc11-post-destroot/base/src/port1.0

Felipe Tanus fotanus at gmail.com
Wed Jun 1 11:33:41 PDT 2011

>From OALD:

validate something:
to prove that something is true; to make something legally valid; to
state officially that something is useful and of an acceptable

to check that something is true or accurate; to show or say that
something is true or accurate

to examine something to see if it is correct, safe or acceptable; to
find out if something/somebody is present, correct or true or if
something is how you think it is

an experiment to discover whether or how well something works, or to
find out more information about it

I think the keyword for our phase is check; it just makes more sense
when compared with what our new phase does.

About the compounded name:
I think the only relation with destroot is that this phase goes just
after it. It's more related to the install.

So, right now I think the best name is check_install, or maybe check_something.

2011/6/1 Blair Zajac <blair at orcaware.com>:
> On Jun 1, 2011, at 7:09 AM, Daniel J. Luke wrote:
>> On Jun 1, 2011, at 10:07 AM, Blair Zajac wrote:
>>> Many packages have a "check" target that runs a unit test, so how about "verify" or "verify_install".  This matches "rpm --verify".
>> verify_destroot?
>> validate_destroot?
> Either is fine with me, but I like the first some a little more.
> Blair
> _______________________________________________
> macports-dev mailing list
> macports-dev at lists.macosforge.org
> http://lists.macosforge.org/mailman/listinfo.cgi/macports-dev

Felipe de Oliveira Tanus
E-mail: fotanus at gmail.com
Blog: http://www.itlife.com.br
Site: http://www.inf.ufrgs.br/~fotanus/
"All we have to decide is what to do with the time that is given us." - Gandalf

More information about the macports-dev mailing list