[78549] trunk/dports/audio/portaudio

Ryan Schmidt ryandesign at macports.org
Thu May 12 08:09:01 PDT 2011

On May 11, 2011, at 20:29, Joshua Root wrote:

>> -distname            pa_stable_v19_20071207
>> +distname            pa_stable_v[strsed ${version} {g/\./_/}]
> 'string map' might be more readable for simple substitutions like this.

My brain seems to remember specific ports where I've done things before in the past, that I keep coming back to to copy code for new ports. I keep going to "whois" to get the code for non-autoconf universal variants, "glib2" for the standard modeline and the branch variable, and "isightcapture" for the strsed code to replace characters in strings. I love regular expressions and reach to them often. I don't remember using string map before, but it looks like you're right, for simple substitutions, it would be simpler. I'll go through and change some strseds to string maps. Thanks for the suggestion.

More information about the macports-dev mailing list