fotanus at gmail.com
Tue May 31 16:07:50 PDT 2011
Sorry about the confusing name. I didn't think right.
I think that it's big enough, and also different enough, to be a
separated phase. Can we keep it apart from destroot?
If yes, I would like to name it test phase. After all, all it does is
test if a package was correctly installed. it would be just after
2011/5/29 Ryan Schmidt <ryandesign at macports.org>:
> On May 29, 2011, at 16:39, Joshua Root wrote:
>>> Revision: 79008
>>> Author: fotanus at macports.org
>>> Date: 2011-05-29 14:27:53 -0700 (Sun, 29 May 2011)
>>> Log Message:
>>> Added post-destroot phase to macports.
>>> Currently, it does nothing.
>>> Modified Paths:
>>> Added Paths:
>> It seems like this could easily be confused with post-destroot. Does
>> your project really need a new target, or could your code be put in a
>> proc run from e.g. destroot_finish?
>> If you really do need a new target, I would suggest calling it something
>> more distinctive, perhaps based on what it does rather than when it
>> happens to run.
> Yes, this commit surprised me. We already have a destroot phase, which of course has pre-destroot and post-destroot hooks, just as the other phases have pre- and post- hooks. Now you're making a new post-destroot phase... will there be pre-post-destroot and post-post-destroot hooks? What if a port has a post-destroot block -- is that a post- hook of the existing destroot phase, or does it overwrite this new post-destroot phase? This is confusing.
> It seems like it should be possible for these checks to occur at the end of the destroot phase, after all its post-destroot blocks have run, and this would be better than making a whole new phase.
Felipe de Oliveira Tanus
E-mail: fotanus at gmail.com
"All we have to decide is what to do with the time that is given us." - Gandalf
More information about the macports-dev