Problem with trace mode in custom installation

Davide Liessi davide.liessi at
Sun Aug 17 07:39:09 PDT 2014

Dear MacPorts developers,

I have some custom installations on my Snow Leopard machine for
testing purposes.
All of them have been installed following the procedure described in
and work without problems.

I tried to install a new version in /opt/macports-x86_64 and I found
out that this folder name breaks trace mode.
Here's what I did:
(I omit apparently regular output; full Terminal transcript is attached)

~ $ /opt/local/bin/svn info /opt/macports-src/trunk/
Percorso: /opt/macports-src/trunk
Working Copy Root Path: /opt/macports-src/trunk
Relative URL: ^/trunk
UUID del Repository: d073be05-634f-4543-b044-5fe20cf6d1d6
Revisione: 124022
Tipo di Nodo: directory
Azione: normale
Autore dell'Ultimo Cambiamento: afb at
Revisione dell'Ultimo Cambiamento: 124022
Data dell'Ultimo Cambiamento: 2014-08-17 15:40:09 +0200(Dom, 17 Ago 2014)

~ $ cd /opt/macports-src/trunk/base/
base $ export PATH=/bin:/sbin:/usr/bin:/usr/sbin
base $ MP_PREFIX=/opt/macports-x86_64
base $ ./configure --prefix=$MP_PREFIX
--with-applications-dir=$MP_PREFIX/Applications --enable-readline
base $ make
base $ sudo make install
base $ cd /opt/macports-x86_64
macports-x86_64 $ sudo ./bin/port -v sync
macports-x86_64 $ sudo ./bin/port -tv install port_cutleaves
--->  Fetching distfiles for port_cutleaves
--->  port_cutleaves-0.1.4.tar.gz doesn't seem to exist in
--->  Attempting to fetch port_cutleaves-0.1.4.tar.gz from
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 30  3804   30  1168    0     0    732      0  0:00:05  0:00:01  0:00:04   732
100  3804  100  3804    0     0   2370      0  0:00:01  0:00:01
--:--:--  257k--->  Verifying checksums for port_cutleaves
--->  Checksumming port_cutleaves-0.1.4.tar.gz
--->  Extracting port_cutleaves
--->  Extracting port_cutleaves-0.1.4.tar.gz
dyld: could not load inserted library:

Error: Failed to extract port_cutleaves.
Error: See /opt/macports-x86_64/var/macports/logs/_opt_macports-x86_64_var_macports_sources_rsync.macports.org_release_tarballs_ports_sysutils_port_cutleaves/port_cutleaves/main.log
for details.
Error: Follow to report a bug.
Error: Processing of port port_cutleaves failed

This happens in the extract phase of every port I tried to install.
I attach also the main.log file.

I tried a number of other folder names, including /opt/macports-64,
/opt/macports_test, /opt/macports-x86, and all of them behave
correctly: only the installation in /opt/macports-x86_64 exhibits the
dyld problem.

Of course I can install in a different prefix, but the folder's name
should not break the software.
If you need more tests, I'll be happy to help, just let me know.

Best wishes.

More information about the macports-dev mailing list