Configuration and environment check command (was: Re: [124047] trunk/base)

Rainer Müller raimue at
Mon Aug 25 03:35:04 PDT 2014


Congratulations to Kyle for landing his Summer of Code from this year
work on trunk!

On 2014-08-17 21:09, ksammons at wrote:
> Revision
>     124047 <>
> Author
>     ksammons at
> Date
>     2014-08-17 12:09:55 -0700 (Sun, 17 Aug 2014)
>       Log Message
> Merge from gsoc14-cleanup. See for details.

However, I am not too happy with naming the command 'port doctor'. Many
other commands used with port(1) are verbs, but using this as a verb
carries the wrong message.

I know where the naming comes from, but there is no need to match any
other terminology and we should rather define our own coherent names.

My proposal would be to rename this to 'port selfcheck' instead.


More information about the macports-dev mailing list