apr-util 1.5.4 fails compile

Bjarne D Mathiesen macintosh at mathiesen.info
Mon Oct 27 05:59:24 PDT 2014

    Hardware Overview:

      Model Name: MacBook Pro
      Model Identifier: MacBookPro8,3
      Processor Name: Intel Core i7
      Processor Speed: 2,2 GHz
      Number of Processors: 1
      Total Number of Cores: 4
      L2 Cache (per Core): 256 KB
      L3 Cache: 6 MB
      Memory: 16 GB
      Boot ROM Version: MBP81.0047.B27
      SMC Version (system): 1.70f6

    System Software Overview:

      System Version: OS X 10.10 (14A389)
      Kernel Version: Darwin 14.0.0
      Boot Mode: Normal
      Secure Virtual Memory: Enabled

apr-util 1.5.4 fails to compile with the following :

:info:build grep: /macports/lib/libltdl.la: No such file or directory
:info:build sed: /macports/lib/libltdl.la: No such file or directory
:info:build libtool: link: `/macports/lib/libltdl.la' is not a valid
libtool archive
:info:build make[1]: *** [dbd/apr_dbd_odbc.la] Error 1
:info:build make[1]: Leaving directory

Now, as far as I can ascertain libltdl.la ought to be provided by
libtool; but libtool doesn't install libltdl.la :-(

$=> ls -l /macports/lib/libltdl.*
-rwxr-xr-x  1 root  admin  35932 25 Okt 15:16 libltdl.7.dylib
-rw-r--r--  1 root  admin  54408 25 Okt 15:16 libltdl.a
lrwxr-xr-x  1 root  admin     15 25 Okt 15:16 libltdl.dylib ->

I've tried to re-install libtool - in the process removing two older
version still present - but still no luck :-(

Does anybody have any hints ???

Bjarne D Mathiesen
København N ; Danmark ; Europa
denne besked er skrevet i et totalt M$-frit miljø
MacOS X 10.10 Yosemite ; 2.8GHz Intel Core i7 ; 16GB 1067MHz DDR3

More information about the macports-dev mailing list