OS-dependent execution/interpretation order?

Ryan Schmidt ryandesign at macports.org
Sun Jan 18 18:10:04 PST 2015

On Jan 18, 2015, at 3:42 AM, René J.V. Bertin wrote:

> On Sunday January 18 2015 02:25:06 Ryan Schmidt wrote:
>>> #46575: submission of the Charm time tracker for Qt4 or Qt5
>> Could you elaborate? I don't know what you're talking about.
> Hmmm, I thought there was enough context on the trac page, including the 2 relevant Portfile versions. In a nutshell, originally I had
> {{{
> configure.args-append -foo ${qt_apps_dir}
> subport qt5-${name} {
>    PortGroup qt5 1.0
>    #...
> }
> if {${subport} ne "qt5-${name}"} {
>    PortGroup qt4 1.0
>    # ...
> }
> }}}
> This worked for me on 10.9 but not for Marko who tried the port directory on 10.6.8 , and got an error about the use of `qt_apps_dir`.
> 2 observations:
> - I probably did not re-run portindex after moving the configure.args-append line to above the PortGroup declarations, which lead to the definition of qt_apps_dir
> - I *think* that Marko tested the port from within the port directory, judging from his remarks, so possibly without having run portindex.

Sorry, I didn't read the Trac page. I just read the subject line of this email thread, and didn't and still don't understand what you're talking about. There is no difference in MacPorts execution or interpretation order based on the OS or OS version. There must be another reason for the problem.

Now that I've had a look at the portfile in question


it seems that you're trying to use the variable ${qt_apps_dir} (on line 18) before having included the qt4-mac (line 26) or qt5-mac (line 20) portgroups in which it's defined.

More information about the macports-dev mailing list