port "activate instead"
René J.V. Bertin
rjvbertin at gmail.com
Mon May 25 15:13:14 PDT 2015
On Monday May 25 2015 23:50:20 Mihai Moldovan wrote:
> That's even worse. gcc is by no means a "replacement" for clang. Maybe
Of course it isn't, it was just another GIGO example ...
> "instead_of" is just a misnomer and it should be "--pre-deactivate" or
Or --swap or --replace; I did give some alternatives.
> something, but even with that ruled out, Raim is right in that the force flag
> would apply to both operations, which is not a good idea. (Think what would
That is true for the solution he gave (I'd consider it a bug but that's a different subject).
There is however no reason at all that the flag would apply to both steps. In fact, I had a "baked-in" version of your script in mind, potentially with in addition a check if any dependency issues created by removing the files from port A get resolved by the files from port B.
> There's nothing stopping you from writing a simple wrapper <snip>
> Extending base and working around the -f problem with even more ambiguity? Not
> so much.
No, just an idea of how to do the dependency checks O:-)
More information about the macports-dev