pyXX-pyobjc-cocoa: consumes gigabytes of memory and never finishes

Mojca Miklavec mojca at
Tue Nov 17 08:33:09 PST 2015

On Tue, Nov 17, 2015 at 5:05 PM, Ryan Schmidt wrote:
> On Nov 17, 2015, at 10:03 AM, Mojca Miklavec wrote:
>> On Tue, Nov 17, 2015 at 5:01 PM, Ryan Schmidt wrote:
>>> On Nov 17, 2015, at 12:33 AM, Mojca Miklavec wrote:
>>>> Since some time I have some serious problem building py35-pyobjc-cocoa on 10.7.
>>>> It consumes all the available memory (it can end up with 6 GB), the
>>>> computer nearly freezes (it becomes unresponsive) and there are no
>>>> visible signs of any progress even though I usually lose the nerves
>>>> before being able to confirm that the process was never going to
>>>> finish.
>>>> I don't see any tickets filed against this port, so I wonder if I'm
>>>> the only one experiencing this problem or if it's indeed just a matter
>>>> of available time and memory before the port gets compiled.
>>> Are you building in parallel? If so, try not building in parallel, i.e. using
>>> sudo port install py35-pyobjc-cocoa
>>> Clang can take more memory than gcc-4.2 did, sometimes a lot more, and this may have been worse with the old versions of Clang you'll find on 10.7.
>>> If it's taking more memory than you have physically installed in the machine, that will result in swapping, which will be very slow, so if you can limit the number of clang processes being started, by not building in parallel, that could end up being faster than building in parallel but swapping.
>> Given what you have written above: should I try using the latest clang
>> compiler then?
> Sure, that would be another thing you could try:
> sudo port install py35-pyobjc-cocoa configure.compiler=macports-clang-3.7

I'm sorry. I forgot to check the details. The current version (3.0.1)
builds just fine. It's version 3.0.4 that hangs. I must have tried to
upgrade to 3.0.4 a while back when there was still no support for 3.5,
so I had to look into the port and then I forgot about the problem
when building other ports.

Does version 3.0.4 work for you?


More information about the macports-dev mailing list