Python + libedit woes

Eric A. Borisch eborisch at
Tue Sep 15 21:35:28 PDT 2015

On Tuesday, September 15, 2015, Joshua Root <jmr at> wrote:

> On 2015-9-16 11:42 , Eric A. Borisch wrote:
> > Any thoughts on this? Are most users not impacted, or have most not
> tried?
> >
> >
> > <>
> >
> > I'm clearly not the only one. :)
> >
> >   - Eric
> [...]
> I don't see the other more serious problems though. It may have
> something to do with the declared terminal type?
> - Josh

I also have one system where it is working, and another where it is not. If
there was ever a need for an interrobang, this is it.

I can't for the life of me figure out what is causing the difference. Same
OS (10.10.5) same Xcode (6.4 / 6E35b) ... I can run with "env -i
/opt/local/bin/python" (remove all envs) and the one still works while the
other is still broken. I even tried forcefully removing and reinstalling
rdepof:python27 (and python27) and re-installing (they all came down from
the buildbot) but it's still broken on one and working on the other...

Hopefully someone else has an idea. I'll have to revisit this another day.
As mentioned, I can fix it by disabling libedit in the Portfile (and let it
use / add dependency upon readline)...

 - Eric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list