Something broke wine

mf2k at mf2k at
Mon Aug 15 06:17:05 PDT 2016

I recently updated wine-devel to 1.9.16 on a computer running El Cap and it no longer works for me. I did this the normal way by running the following which also updates all of my installed ports:
sudo port selfupdate
sudo port upgrade outdated

Here are the errors I see in Terminal:

$ wine myapp.exe
err:winediag:nulldrv_CreateWindow Application tried to create a window, but no driver could be loaded.
err:winediag:nulldrv_CreateWindow The explorer process failed to start.
err:ole:apartment_createwindowifneeded CreateWindow failed with error 0

So I went back to the previous version of wine-devel (1.9.15), which worked fine. Yet it still did not work. I had to revert all of the ports which were updated at the same time to get it working again. So I think it was a dependency, not wine itself that is the problem. I tried installing both wine and wine-devel from scratch on another computer and neither of them worked either, failing with the same error(s). 

So here are all of the ports that were updated (these are the old versions, not the latest). I assume one of them is culprit. Can anyone help me debug how to get wine working again? Is anyone else seeing this problem when completely up to date?

cmake @3.6.0_0+universal
curl @7.50.0_0+ssl+universal
curl-ca-bundle @7.50.0_0
ffmpeg-devel @20160709_0+gpl2+x11
fontconfig @2.12.0_1+universal
gnutls @3.4.13_0+universal
harfbuzz @1.2.7_0+universal
iso-codes @3.68_0
libedit @20160618-3.1_0+universal
libepoxy @1.3.1_1+python35+universal
libpcap @1.7.4_0+universal
libpng @1.6.23_0+universal
p5.22-io-socket-ip @0.370.0_0
p5.22-io-socket-ssl @2.33.0_0
p5.22-net-ssleay @1.740.0_0+universal
p5.22-sub-uplevel @0.250.0_0
p5.22-test-simple @1.302.47_0
pcre @8.38_0+universal
py27-setuptools @21.2.1_0
sqlite3 @3.13.0_0+universal


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list