Can't find local, correctly indexed Portfile

Bill Barnhart barnhartwd at
Tue Jul 5 08:40:02 PDT 2016

That worked. I had not needed to update sources.conf on previous computers,
so I wasn't aware of this. Thanks

On Tue, Jul 5, 2016 at 10:28 AM, Joshua Root <jmr at> wrote:

> On 2016-7-6 01:22 , Bill Barnhart wrote:
>>  I am trying to build a program from a local Portfile. After setting up
>> the
>>  proper directory structure, placing the Portfile in it, and running
>> portindex,
>>  the port is correctly and successfully parsed. When I run port install on
>>  the program, though, I get an error stating that the previously indexed
>> port cannot be
>>  found. I am running El Capitan v10.11.5, and macports works fine on non-
>>  local port repositories. This particular local portfile also works fine
>> on
>>  previous OS versions (i.e. Yosemite 10.10.5), so this should not be an
>> issue with the Portfile itself.
>>  I'm not sure where this error is originating from or why the portfile
>> can't be found after being correctly indexed and parsed. Any suggestions
>> would be helpful.
> Sorry if this is asking the obvious, but have you checked that your
> sources.conf has the correct path to your local repo?
> - Josh

William D. Barnhart

Assistant Professor
Earth and Environmental Sciences
University of Iowa
Iowa City, IA 52242
william-barnhart-1 at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list