pixilla at macports.org
Sun Mar 6 11:41:25 PST 2016
> On Mar 6, 2016, at 11:22 AM, Mojca Miklavec <mojca at macports.org> wrote:
> On 6 March 2016 at 18:01, Bradley Giesbrecht wrote:
>> We could remove all ports that depend on mysql4 and mysql5 exclusively or
>> via default variants. The remaining ports would then have their mysql4 or
>> mysql5 variant removed.
>> The removed ports could be brought back if someone was interested in fixing
> That would be a bit harsh, wouldn't it? I bet that a number of ports
> would work with a different database without any additional patches.
> I asked long ago if someone could provide guidelines for transition,
> but nobody did. It's not clear to me what the suggested way is, so
> that we could at least make some consistent changes rather than every
> port switching to a different database with completely different code.
I propose that someone other then me fix base to allow variants with the same naming convention as port names. This would allow variants with hyphens and dots. So the hyphens will be problematic, ok.
But the dots are somewhat important. Is +mariadb_101 mariadb 1.01 10.1 or 100?
I looked at updating base to allow dots in variant names and it didn’t look to difficult, at one point a I had a patch that worked in my testing, but I didn’t feel comfortable enough with base to make the change and the discussion on the list didn’t get much traction although I remember people mentioning it would be good to not have ambiguous version strings in names of ports and variants.
Coming up with a standard variant name for the mariadb-10.0 and mariadb-10.1 is the place to start in my opinion.
A second thought is to create a mysql portgroup which sets some helper variables like $mysql_lib_path, $mysql_include_path and $mysql_config_path. The portgroup might also have a method to create mysql stub variants to enforce variant naming conventions with commented code blocks to show how to test if a variant is active and examples of using the portgroups helper variables.
Can we get dots in variant names into base soon?
If not, what should be the standard for variant names when the port it is targeting has dots in its name?
More information about the macports-dev