Error writing data to TLS socket: The specified session has been invalidated for some reason.

Kenneth F. Cunningham ken.cunningham.webuse at
Mon Jan 28 00:21:23 UTC 2019

On 2019-01-27, at 10:33 AM, Ryan Schmidt wrote:

> On Jan 27, 2019, at 06:24, Marius Schamschula wrote:
>> On Jan 26, 2019, at 9:03 PM, Ken Cunningham wrote:
>>> Running the test suite on gnutls on 10.6.8 shows one failure:
>>> FAIL: srp
>> For gnutls 3.6.6 the test suite runs clean under High Sierra: only a few XFAIL, not a single FAIL.
> Ken, what compiler did you build gnutls with? You might try a different one and see if the problem persists.

I have to admit I tried several -- even pushed it over the gcc8 on 10.6.8 to see if that might work.

At the moment, the most functional browsers on older systems are based on webkit2-gtk -- surf or epiphany wrap that.  Updating webkit2-gtk is hard. 

I guess I will roll back to gnutls 3.5.x until things are more sorted in that arena; it must be the new TLS 1.3 and associated protocols in the gnutls 3.6.x branch -- or maybe the way our current version of webkit2-gtk uses it. I tried rebuilding webkit2-gtk but just got the same errors.

Will report back if I ever figure it out. Probably will just be fixed upstream (gnutls or webkit2-gtk, not sure which).


More information about the macports-dev mailing list