Set CC to clang++

Steven Smith steve.t.smith at
Fri Nov 22 12:25:20 UTC 2019

None of these hacks worked, and I believe I’m barking up the wrong tree.

I’ll post the submission, show the error, and initiate a new thread.

I now believe it’s some MacPorts compile- or link-time flag setting that’s causing this issue.

> On Nov 21, 2019, at 21:09, Steven Smith <steve.t.smith at> wrote:
> I’m trying to build jsonnet <> (dependency of a larger project).
> jsonnet fails to build on macOS with the exact same error others observe, e.g. <>.
>> Undefined symbols for architecture x86_64:
>>            "_jsonnet_destroy", referenced from:
> If the CC=clang++ hack thing doesn’t work, I’l just commit the whole project and show the error in the build bot.
>> On Nov 21, 2019, at 20:49, Joshua Root <jmr at> wrote:
>>> On 2019-11-22 12:18 , Steven Smith wrote:
>>> Thanks. I’m just trying to hack around the error:
>>>> |Undefinedsymbols forarchitecture x86_64|
>> The important thing is which symbols are missing and why. Seeing the
>> exact link command would be useful. Can you share a build log?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3898 bytes
Desc: not available
URL: <>

More information about the macports-dev mailing list