gcc won't build i386 with our cctools assembler hack

Ken Cunningham ken.cunningham.webuse at gmail.com
Tue Feb 25 14:58:00 UTC 2020

building i386, gcc 5,6,7,8 misconfigures when our "as" redirects it to clang for assembly, following our hack in cctools to do that. the gcc build then fails.

I have not so far been able to overcome this other than:

1. deactivating all clangs 5+ prior to the build, to get the old gas 


2. defaulting gcc to use --with-as=/usr/bin/as

Having the built gcc forever use /usr/bin/as as assembler would be awful, so option 1 looks better than 2. but ugh.

I tried many things. gcc is complicated to build when you want it to do non-standard stuff. There may be some way to make it work...pls chime in...but I have likely tried it. 

passing in a specific ENV var to the stage1 compiler, or adding -Wa,-Q to the stage1 C and CXX flags, would probably be enough to fix it.

Otherwise appears we will have to conflicts_build a bunch of clangs when building i386, which is a pain, esp if no buildbot to build it clean for us.


More information about the macports-dev mailing list