How to force run tests as non-root?

Sergio Had vital.had at
Sun Feb 25 03:06:21 UTC 2024

Could you reproduce the issue? I tried a number of ways to fix that, but nothing worked.
Sudo anything does not work from the portfile code, and I am not sure how to otherwise emulate “sudo -u normal-non-root-user”.

(If you got no arm64 hardware, presumably things will be the same on recent-enough x86_64, though I cannot verify that. For the same reason I cannot try running tests with 2.x version, as there is no Qt5 support in it.)
On Feb 25, 2024 at 04:49 +0700, Ken Cunningham <ken.cunningham.webuse at>, wrote:
> You are completely right, and I was wrong about this.
> I am now not certain how it came to be that macports was installed under the root user for the 10.6-ppc installation in the mentioned ticket (assuming I got the part right).
> K
> > On Feb 24, 2024, at 13:07, Joshua Root <jmr at> wrote:
> >
> > On 25/2/2024 03:07, Ken Cunningham wrote:
> > > Some of your macports installations are installed as the root user, instead of the macports user.
> > > This happened because there is no installer for 10.6-ppc to automatically create the macports user. You have an open ticket about this too, where I pointed to the commands to be run to generate the macports user.
> > > Sooner or later you will probably have to fix this.
> >
> > It shouldn't make any difference to this whether you use the pkg installer or install from source, since the Makefile also creates the run user. Unless of course you specifically tell configure --with-macports-user=root (very not recommended).
> >
> > - Josh
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-dev mailing list