10.5 and gcc8 x86-64 ok but ppc bails with dlerror

Riccardo Mottola riccardo.mottola at libero.it
Thu Mar 28 15:57:52 UTC 2024


after all the talk about gcc versions, I tried to build gcc 8 here.
Officially it says "gcc8 is known to fail".

I first did just "build" on Intel 64bit and PPC 32bit - Intel 32bit
later, I fear my MacBook has fan issues.

Intel 64bit finished build! Took several hours. I thus tried to install
it... and it says again
"libgcc8 is known to fail. Try to install anyway?" and yes, it just built!

However then it asks about libgcc9.... but I want to stay on libgcc8,
that was the point... am Inheriting that it will go up to gcc13?

On PowerPC instead build fails (and ultimate goal is to enable newer
gccs on PPC too, where it is needed)

:info:build cc1plus: warning: '-mdynamic-no-pic' overrides '-fpic',
'-fPIC', '-fpie' or '-fPIE'
In member function 'gcc::jit::result*
error: 'dlerror' was not declared in this scope
:info:build    dlerror ();
:info:build    ^~~~~~~

Already seen this? Full build log is 6.7MB
Should I open a ticket on this or is there already one for gcc8 efforts?
didn't find it.


More information about the macports-dev mailing list