[MacPorts] #14997: port commands not working

MacPorts trac at macosforge.org
Sun Apr 13 03:17:21 PDT 2008

#14997: port commands not working
 Reporter:  beier at post.cybercity.dk  |       Owner:  macports-tickets at lists.macosforge.org
     Type:  defect                   |      Status:  new                                  
 Priority:  Normal                   |   Milestone:                                       
Component:  ports                    |     Version:  1.6.0                                
 Keywords:  ports                    |  

 I have now tried several times tio install Macports i order to get GIMP
 running, but I am not very successful.

 I'am running MAC OS X 10.5.2 on a Macbook Pro (intel based) and have
 followed the guide at http://guide.macports.org/#installing using method
 2.3.1. Mac OS X Package Install

 1) After this I cannot see the mentioned .profile which should have been
 created automatically during the installation process.
 2) If I open X11 and type the commands in this window It looks like this
 ''''bash-3.2$ port search gimp
 bash: port: command not found
 3) If I try the same in the MAC application Terminal, I get the same
 result as described under 2)
 4) If I click on opt/local/bin/port and type the commands, I get the
 Last login: Sun Apr 13 11:45:15 on ttys001
 /opt/local/bin/port ; exit;
 You have mail.
 Arctic-Dive-Travel:~ morten$ /opt/local/bin/port ; exit;
 MacPorts 1.600
 Entering interactive mode... ("help" for help, "quit" to quit)
 [Users/morten] > port search gimp
 Unrecognized action "port"
 [Users/morten] > sudo port selfupdate
 Unrecognized action "sudo"

 I am definately new to this game, so maybe I make some stupid mistake
 somewhere - please help ! :-)

 p.S I have also tried to install GIMP via
 http://darwingimp.sourceforge.net/ if I try to run GIMP I get following
 message - maybe that is useful?:
 Dyld Error Message:
   Library not loaded: /usr/X11/lib/libXrandr.2.dylib
   Referenced from:
   Reason: Incompatible library version: libgtk-x11-2.0.0.dylib requires
 version 4.0.0 or later, but libXrandr.2.dylib provides version 3.0.0

Ticket URL: <http://trac.macosforge.org/projects/macports/ticket/14997>
MacPorts </projects/macports>
Ports system for Mac OS

More information about the macports-tickets mailing list