[MacPorts] #13292: vim fails to configure, tgetent() not found

MacPorts trac at macosforge.org
Sun Apr 13 23:13:45 PDT 2008

#13292: vim fails to configure, tgetent() not found
  Reporter:  griff.rees at gmail.com  |       Owner:  raimue at macports.org
      Type:  defect                |      Status:  reopened           
  Priority:  Normal                |   Milestone:  Port Bugs          
 Component:  ports                 |     Version:  1.5.0              
Resolution:                        |    Keywords:                     
Comment (by olivier at olivieryiptong.com):

 Replying to [comment:18 olivier at olivieryiptong.com]:
 > I run a core 2 duo MBP running Leopard and trying to install vim using
 macports gives me the tgetent() error as well.
 > However, it is important to note that this only occurs when adding the
 +ruby option.
 > I set the configuration options to +python and +perl and it worked fine.
 ncurses is installed properly and other applications depending upon it
 seem to be working fine. The issue seems to be directly related to using
 the +ruby option, since it compiles fine with ncurses without that option.

 Oops, my bad, I didn't read the last comments. Both Ruby and Python are
 not macports installations.

Ticket URL: <http://trac.macosforge.org/projects/macports/ticket/13292#comment:19>
MacPorts </projects/macports>
Ports system for Mac OS

More information about the macports-tickets mailing list