[MacPorts] #13854: p5-sdl_perl: library not found for -lSDL_ttf

Lis lisfolks.lists at gmail.com
Sat May 10 20:46:26 PDT 2008

I tried installing again, but got same error.  Then, thinking I needed
to possibly upgrade some ports (probably stupidly), I ran 'sudo port
-u upgrade vile'.  It stopped with an error, so I ran 'sudo port clean
vile', followed by 'sudo port clean --all vile'.  Then, I tried to run
'sudo port install p5-sdl_perl' again - but now I'm getting this:

Error: Unable to execute port: can't read "configure.universal_archs":
no such variable

What did I do, and/or, what do I need to do to fix this?

I did get the same error prior to this, though - the 'library not
found for -lSDL_ttf'...

On Sat, May 3, 2008 at 4:18 PM, MacPorts <trac at macosforge.org> wrote:
> #13854: p5-sdl_perl:  library not found for -lSDL_ttf
> ---------------------------------------+------------------------------------
>  Reporter:  lisfolks.lists at gmail.com  |       Owner:  macports-tickets at lists.macosforge.org
>      Type:  defect                    |      Status:  new
>  Priority:  Normal                    |   Milestone:  Port Bugs
>  Component:  ports                     |     Version:  1.6.0
> Resolution:                            |    Keywords:
> ---------------------------------------+------------------------------------
> Comment (by sethk at meowfishies.com):
>  Added a patch to link against the normal libraries in ${prefix}/lib
>  instead of using the frameworks.  Please test.
> --
> Ticket URL: <http://trac.macosforge.org/projects/macports/ticket/13854#comment:5>
> MacPorts </projects/macports>
> Ports system for Mac OS

More information about the macports-tickets mailing list