[MacPorts] #15416: R 2.7 Port (gnu-r): Tk interface does not work

MacPorts noreply at macports.org
Fri May 23 18:41:21 PDT 2008

#15416: R 2.7 Port (gnu-r): Tk interface does not work
 Reporter:  mark.m.fredrickson at gmail.com  |       Owner:  macports-tickets at lists.macosforge.org
     Type:  defect                        |      Status:  new                                  
 Priority:  Normal                        |   Milestone:                                       
Component:  ports                         |     Version:  1.6.0                                
 Keywords:                                |  
 The R 2.6.2 port worked with no special effort with the Tk interface. The
 2.7 port does not work on my system.


 > install.packages("xtable")
 Warning in install.packages("xtable") :
   'lib = "/opt/local/lib/R/library"' is not writable
 Would you like to create a personal library
 to install packages into?  (y/n)
 --- Please select a CRAN mirror for use in this session ---
 Loading Tcl/Tk interface ... Error in fun(...) : couldn't connect to
 display "0.0"
 Error: .onLoad failed in 'loadNamespace' for 'tcltk'


 I have

 tk                             @8.5.2          x11/tk
 tcl                            @8.5.2          lang/tcl


 I have also tried the other drivers that my {{{$ r --help}}} lists with
 similar results.

 On a similar note: why is --without-aqua a required option? What would it
 take to build a version that uses Quartz?


Ticket URL: <http://trac.macports.org/ticket/15416>
MacPorts <http://www.macports.org/>
Ports system for Mac OS

More information about the macports-tickets mailing list