[MacPorts] #24042: mpd runs as root

MacPorts noreply at macports.org
Thu Apr 8 13:28:29 PDT 2010

#24042: mpd runs as root
 Reporter:  greg-macports@…        |       Owner:  milosh@…           
     Type:  defect                 |      Status:  new                
 Priority:  Normal                 |   Milestone:                     
Component:  ports                  |     Version:  1.8.2              
 Keywords:                         |        Port:  mpd                

Comment(by diane@…):

 Hi, I tried using the mpd.diff patch on OS X 10.6.3 and ran into a couple
 of problems. the minor issue was the patch by default ended up creating a
 user with a uid > 500 which I think is supposed to be for real users
 instead of daemons. (In trying to diagnose the following problem I deleted
 the default user and created a new one with a user and group ID < 500
 using dscl.

 The more important problem is that I kept getting error
 Bug: launchd_core_logic.c:1685 (24003):22

 with the patched mpd.wrapper script when using su _mpd -c "[mpd command
 line]", then I changed the script to sudo -u _mpd [mpd command line]
 which worked.

Ticket URL: <http://trac.macports.org/ticket/24042#comment:7>
MacPorts <http://www.macports.org/>
Ports system for Mac OS

More information about the macports-tickets mailing list