[MacPorts] #24599: Error 2 while trying to install zlib on OS X 10.6.3

MacPorts noreply at macports.org
Thu Apr 22 10:16:41 PDT 2010

#24599: Error 2 while trying to install zlib on OS X 10.6.3
 Reporter:  trichard@…               |       Owner:  macports-tickets@…                   
     Type:  defect                   |      Status:  new                                  
 Priority:  Normal                   |   Milestone:                                       
Component:  ports                    |     Version:  1.8.2                                
 Keywords:                           |        Port:                                       

 i just set up a new imac with all up to date Apple software (10.6.3,
 Macports 1.8.2) and tried to install mysql on the system.

 I received the following error:

 --->  Computing dependencies for mysql5
 --->  Staging zlib into destroot
 Error: Target org.macports.destroot returned: shell command " cd
 && /usr/bin/make install
 " returned error 2
 Command output: cp libz.a
 usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file
        cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ...
 make: *** [install-libs] Error 64

 Error: The following dependencies failed to build: openssl zlib readline
 Error: Status 1 encountered during processing.
 Before reporting a bug, first run the command again with the -d flag to
 get complete output.

 then I tried to install ffmpeg or ImageMagick and i allways encountered
 the same message.

 so i tried to install zlib... same message.

 I've checked the permissions in

 everything seems to be ok.

 What's going wrong with the zlib installation?

 Thanks in advance


Ticket URL: <http://trac.macports.org/ticket/24599>
MacPorts <http://www.macports.org/>
Ports system for Mac OS

More information about the macports-tickets mailing list