[MacPorts] #29340: NUT @2.4.1 libusb not found during build

MacPorts noreply at macports.org
Mon May 2 01:02:05 PDT 2011

#29340: NUT @2.4.1 libusb not found during build
 Reporter:  rav3n@…              |       Owner:  macports-tickets@…                   
     Type:  defect               |      Status:  new                                  
 Priority:  Normal               |   Milestone:                                       
Component:  ports                |     Version:  1.9.2                                
 Keywords:  install failure      |        Port:  nut                                  
 Hi, I'm trying to install Network UPS 2.4.1 (NUT)  using ports, support
 for usb connected UPS in the form of the usbhid-ups driver is not being
 built even though libusb is present.
 [[br]]I've tried 'port install NUT' and letting it fetch libusb and tried
 separately installing libusb and then installing NUT. 'port' clearly
 thinks libusb is present after its fetched it but the NUT build scripts do
 not and I can see the libusb libraries in /opt/local/lib
 [[br]]I ran the NUT configure script manually with option '--with-usb' to
 try to force it but the message configure gives is 'usb requested but
 libusb not present' but it is?
 [[br]]I cant find this in the forums so apologies for the new ticket, any
 help most grateful.
 Running Darwin 10.7

Ticket URL: <https://trac.macports.org/ticket/29340>
MacPorts <http://www.macports.org/>
Ports system for Mac OS

More information about the macports-tickets mailing list