[MacPorts] #47353: Can't update ports after upgrade to 2.3.3

MacPorts noreply at macports.org
Sat Apr 4 18:20:25 PDT 2015

#47353: Can't update ports after upgrade to 2.3.3
 Reporter:  jczech@…             |      Owner:  macports-tickets@…
     Type:  defect               |     Status:  new
 Priority:  Normal               |  Milestone:
Component:  ports                |    Version:  2.3.3
 Keywords:  ports upgrade rsync  |       Port:
 I have had MacPorts running successfully on this 10.7.5 box.  I primarily
 use it for MRTG, and haven't updated in quite a while.

 Yesterday, I ran the selfupdate and upgrade to 2.3.3 (not sure, of the
 previous version, but likely 2.2.?, or maybe older.)  The update was
 successful, but when I ran 'sudo port upgrade outdated' I received an

 ''Error: Unable to execute port: couldn't open
 permission denied''

 I have searched for related issues and tried similar fixes, as well as
 trying to reinstall 2.3.3 over top of itself.  I also looked for the
 "/opt/local/var/macports..." directory but it doesn't exist.  Apparently
 something significant has changed from my older version.

 Any help or guidance to repair would be greatly appreciated.  I can still
 start MRTG, etc., but can't upgrade the ports.

Ticket URL: <https://trac.macports.org/ticket/47353>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list