[MacPorts] #47554: openconnect compiled without UTUN support

MacPorts noreply at macports.org
Thu Apr 23 19:01:04 PDT 2015

#47554: openconnect compiled without UTUN support
 Reporter:  tte@…             |      Owner:  macports-tickets@…
     Type:  defect            |     Status:  new
 Priority:  Normal            |  Milestone:
Component:  ports             |    Version:  2.3.3
 Keywords:  openconnect utun  |       Port:  openconnect
 Installed latest openconnect 7.05 from ports onto MacOS 10.8.2.
 Starting OpenConnect results in error messge:
 Failed to open tun device: Invalid argument

 .. but i did not want to install/use the 'tun' interface, but instead
 MacOS standard utun interface as supported by openconnect since 7.0

 When i downloaded openconnect from http://www.infradead.org/openconnect/
 and tried to compile myself, ./configure complained about IF_UTUN... not
 to compile, so the config file created did not include UTUN support. I did
 manually changed it and it compiled fine and worked fine. I do suspect
 that the port binary of openconnect might have had the same problem in
 compilation. I did not try to investigate why that compile problem exist
 (autoconfigure scripts are too complex).

 ALso note that the vpnc script that was installed by port openconnect
 seems to be quite outdated, aka: the package should be compiled with the
 latest downloaded from git.

Ticket URL: <https://trac.macports.org/ticket/47554>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list