[MacPorts] #46879: command execution failed when reinstalling octave with gl2ps

MacPorts noreply at macports.org
Mon Feb 16 05:25:51 PST 2015

#46879: command execution failed when reinstalling octave with gl2ps
 Reporter:  rspinney20@…       |      Owner:  macports-tickets@…
     Type:  defect             |     Status:  new
 Priority:  Normal             |  Milestone:
Component:  ports              |    Version:  2.3.3
 Keywords:  octave fltk gl2ps  |       Port:  octave

 I'm attempting to install octave on OSX 10.8.5

 Salient facts:

 1. I had successfully installed octave with "sudo port install octave
 +atlas". It was working.
 2. I needed to use the fltk graphics interface (the gnuplot one doesn't
 support all the moving labels etc. fully) so I uninstalled octave,
 installed fltk (through macports), then reinstalled octave. This too
 worked and I was successfully plotting within FLTK GL windows.
 3. Miserably (I have no idea why these packages are not simply listed as
 dependencies), one cannot save figures with the fltk graphics interface
 without gl2ps being installed and it is not a dependency, so I uninstalled
 fltk and octave, installed gl2ps, installed fltk, but when I came to
 installed octave, I got an error:

 --->  Building octave
 Error: org.macports.build for port octave returned: command execution
 Please see the log file for port octave for details:
 To report a bug, follow the instructions in the guide:
 Error: Processing of port octave failed

 Things I have tried:

 1. sudo port selfupdate
 2. sudo port upgrade outdated
 3. totally uninstalled macports (following instructions here
 then started from scratch.

 But after trying everything I still get the same error.

 By a process of trial and error I get these results based on the
 permutations (of installations of gl2ps, fltk) I get

 gl2ps: not installed
 fltk: not installed
 octave: builds!

 gl2ps: installed
 fltk: not installed
 octave: builds

 gl2ps: installed
 fltk: not installed
 octave: builds!

 gl2ps: installed
 fltk: installed
 octave: build fails!

 which would indicate that including gl2ps, as part of fltk, is what is
 causing trouble. But I need to save my figures! I don't see the point of
 being able to use the flexibility of the fltk graphing toolkit, but not be
 able to save the figures. Does anyone have any suggestions?

 I attach the compressed main.log file



Ticket URL: <https://trac.macports.org/ticket/46879>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list