[MacPorts] #46953: fontconfig @2.11.1 configure error -build failure

MacPorts noreply at macports.org
Tue Feb 24 10:34:21 PST 2015

#46953: fontconfig @2.11.1 configure error -build failure
 Reporter:  mhng1580@…               |      Owner:  macports-tickets@…
     Type:  defect                   |     Status:  new
 Priority:  Normal                   |  Milestone:
Component:  ports                    |    Version:  2.3.3
 Keywords:  fontconfig expat         |       Port:  fontconfig expat
  libxml2 mac10.9.5                  |  libxml2
 I get the following error when I tried to install fontconfig
 --->  Rebuilding in order
      fontconfig @2.11.1
 --->  Computing dependencies for fontconfig
 --->  Fetching distfiles for fontconfig
 --->  Verifying checksums for fontconfig
 --->  Extracting fontconfig
 --->  Applying patches to fontconfig
 --->  Configuring fontconfig
 Error: Failed to configure fontconfig, consult
 Error: org.macports.configure for port fontconfig returned: configure
 failure: command execution failed
 Please see the log file for port fontconfig for details:
 Error: Unable to upgrade port: 1
 Error rebuilding fontconfig
     while executing
 "error "Error rebuilding $portname""
     (procedure "revupgrade_scanandrebuild" line 395)
     invoked from within
 "revupgrade_scanandrebuild broken_port_counts $opts"
     (procedure "macports::revupgrade" line 5)
     invoked from within
 "macports::revupgrade $opts"
     (procedure "action_revupgrade" line 2)
     invoked from within
 "action_revupgrade $action $portlist $opts"
     (procedure "action_target" line 96)
     invoked from within
 "$action_proc $action $portlist [array get global_options]"
     (procedure "process_cmd" line 103)
     invoked from within
 "process_cmd $remaining_args"
     invoked from within
 "if { [llength $remaining_args] > 0 } {

     # If there are remaining arguments, process those as a command
     set exit_status [process_cmd $remaining..."
     (file "/opt/local/bin/port" line 5268)

 I checked the main.log file, and it showed
 expat is required. or try to use --enable-libxml2
 But when I tried to rebuild expat and xml2, it seems that they both depend
 on fontconfig and the same error when building fontconfig shows up again.

Ticket URL: <https://trac.macports.org/ticket/46953>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list