[MacPorts] #48127: npm 2.11.2 fails user prefix build

MacPorts noreply at macports.org
Sun Jun 21 07:19:37 PDT 2015

#48127: npm 2.11.2 fails user prefix build
  Reporter:  mtb19@…  |      Owner:  macports-tickets@…
      Type:  defect   |     Status:  new
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:  2.3.3
Resolution:           |   Keywords:
      Port:  npm      |

Comment (by mtb19@…):

 For kicks, I created `[[PREFIX]]/bin/rimraf` as follows:

 #!/usr/bin/env sh
 set -ex
 echo "${0}"
 exec rm -fr ${1+"${@}"}

 Then I ran `port clean --all npm && port install npm`. It "worked" (new
 main.log attached).

 I'm curious why @ryandesign's build would find `rimraf` (and where), but
 mine wouldn't.

 Could this be solved by temporarily augmenting `PATH` during the build

 For what it's worth, I can install a localized `npm` into `${HOME}/.npm`
 ([http://www.johnpapa.net/how-to-use-npm-global-without-sudo-on-osx/ per
 these instructions]) without issue, so I'm not sure it's an upstream
 packaging issue? It might be, but I doubt I'll get much traction there.

Ticket URL: <https://trac.macports.org/ticket/48127#comment:3>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list