[MacPorts] #48152: wxMaxima will not launch unless explicitly called with "open" command

MacPorts noreply at macports.org
Thu Jun 25 17:59:05 PDT 2015

#48152: wxMaxima will not launch unless explicitly called with "open" command
  Reporter:  m74z00219@…  |      Owner:  mk@…
      Type:  defect       |     Status:  new
  Priority:  Normal       |  Milestone:
 Component:  ports        |    Version:
Resolution:               |   Keywords:
      Port:  wxMaxima     |

Comment (by m74z00219@…):

 Replying to [comment:16 ryandesign@…]:
 > Replying to [comment:12 m74z00219@…]:
 > > It simply doesn't execute; the output is "-bash: wxmaxima: command not
 > Does /opt/local/bin/wxmaxima exist? I presume it doesn't. I downloaded
 the most recent pre-compiled binary of wxMaxima from our packages server
 and verified it does not contain such a file. Also, wxMaxima was last
 updated one year ago; it hasn't changed since then.
 > Replying to [comment:14 m74z00219@…]:
 > > IIRC, it last worked before following the advice to delete this*
 symlink /opt/local/share/aclocal/wxwin.m4 (#48152). Actually, this symlink
 seems to have returned.
 > m4 files are used for building software; they are not related to running
 > > Trying "port provides /opt/local/share/aclocal/wxwin.m4" returns
 "/opt/local/share/aclocal/wxwin.m4 is not provided by a MacPorts port."
 > The message is correct; that file would not be provided by installing a
 MacPorts port; rather, it would be provided by running "sudo port select
 > Replying to [comment:15 m74z00219@…]:
 > > Yes, that would work; but something must have gone wrong with my
 macports installation since wxmaxima used to launch when invoking it
 simply with "wxmaxima."
 > Does running
 > {{{
 > /Applications/MacPorts/wxMaxima.app/Contents/MacOS/wxmaxima
 > }}}
 > work for you? Mojca said it didn't work for her, but if it works for
 you, perhaps you formerly had
 /Applications/MacPorts/wxMaxima.app/Contents/MacOS in your `PATH`.
 However, as we said above, that's not the normal way to run an OS X
 application. Use `open -a`.

 Queer, "/opt/local/bin/wxmaxima" does not exist! This, I presume, is the
 source of my trouble. What could I do about this?

 I tried running
 "/Applications/MacPorts/wxMaxima.app/Contents/MacOS/wxmaxima" and I got

 ../src/osx/core/bitmap.cpp(1295): assert "image.IsOk()" failed in
 wxBitmap(): invalid image
 Collecting stack trace information, please wait...An admin user name and
 password is required to enter Developer Mode.
 Admin user name (cdr35):

 I entered my credentials and it gave me this:
 atos[72079]: [fatal]  child process status could not be determined; exit
 code unavailable.}}}

 Then, wxmaxima did launch, but gave me an ugly message box.
 wxWidgets Debug Alert

 ../src/osx/core/bitmap.cpp(1295): assert "image.IsOk()" failed in
 wxBitmap(): invalid image

 Call stack:
 [00] wxMaximaFrame::SetupToolBar()
 [01] wxMaximaFrame::wxMaximaFrame(wxWindow*, int, wxString const&, wxPoint
 const&, wxSize const&, long)
 [02] wxMaxima::wxMaxima(wxWindow*, int, wxString, wxPoint, wxSize)
 [03] MyApp::NewWindow(wxString)
 [04] MyApp::OnInit()
 [05] wxApp::CallOnInit()
 [06] wxEntry(int&, wchar_t**)
 [07] main
 [08] start

 Do you want to stop the program?
 You can also choose [Cancel] to suppress further warnings.

 Next, I chose "cancel" and then "Segmentation fault: 11" was spit out to
 the terminal after wxmaxima crashed.

 Last, I repeated the process, this time selecting "no." It gave me a
 couple more error boxes to go through before finally crashing.


Ticket URL: <https://trac.macports.org/ticket/48152#comment:17>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list