[MacPorts] #48179: can not port anything

MacPorts noreply at macports.org
Fri Jun 26 10:30:24 PDT 2015

#48179: can not port anything
 Reporter:  swen@…  |      Owner:  macports-tickets@…
     Type:  defect  |     Status:  new
 Priority:  High    |  Milestone:
Component:  ports   |    Version:  2.3.3
 Keywords:          |       Port:
 Hi,I installed macport on my desktop which I do not have root access. The
 configure I used is:

 ./configure --prefix=/Users/wen/macport --with-no-root-privileges --with-
 install-user=wen --with-macports-user=wen --with-install-group=nogroup

 after installing MacPort, I tried to use it to port cmake and qt5, but it
 can not find cmake:

 hollyhock:bin wen6$ port install cmake

 Error: Port cmake not found

 It happens to others too, qt5, vim...

 I tried to update the tree, but I get the error:

 hollyhock:bin wen6$ port sync

 --->  Updating the ports tree

 Error: Synchronization of the local ports tree failed doing rsync

 port sync failed: Synchronization of 1 source(s) failed

 Can you help me so I can use MacPort?

Ticket URL: <https://trac.macports.org/ticket/48179>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list