[MacPorts] #50969: Provide a generic extract (and compress) commands in base

MacPorts noreply at macports.org
Thu Apr 7 18:02:27 PDT 2016

#50969: Provide a generic extract (and compress) commands in base
  Reporter:  mojca@…      |      Owner:  raimue@…
      Type:  enhancement  |     Status:  new
  Priority:  Normal       |  Milestone:
 Component:  base         |    Version:  2.3.4
Resolution:               |   Keywords:
      Port:               |

Comment (by mojca@…):

 I agree that if we add `file_extract`, `file_compress`, ... adding
 `file_fetch` would be a a natural follower.

 But if I understand correctly the only reason why you need to rewrite the
 fetching phase yourself in this particular example is because you want to
 rename the file afterwards to prevent clashes? I usually worked around
 that by using `dist_subdir`, but again `dist_subdir` is global to the
 port, so if your ports need one huge file that doesn't change (but is
 properly versioned) and another small file that doesn't change the name
 (perhaps it changes just the URL) and keeps changing on regular basis,
 using `dist_subdir` is very suboptimal.

 Supporting renaming of files is not a completely unreasonable request. In
 particular not in the context of adding more flexibility like different
 suffixes / extract methods, files with the same name from different URLs,
 very unfortunate filenames, fetching files to different dist_subdir-s, ...
 who knows what else. But it would require a different syntax.

Ticket URL: <https://trac.macports.org/ticket/50969#comment:5>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list