[MacPorts] #46658: pulseaudio @5.0_1: builds but doesn't work

MacPorts noreply at macports.org
Fri Dec 16 08:44:18 CET 2016

#46658: pulseaudio @5.0_1: builds but doesn't work
  Reporter:  RJVB        |      Owner:  Ionic
      Type:  defect      |     Status:  reopened
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:  2.3.3
Resolution:              |   Keywords:
      Port:  pulseaudio  |

Comment (by RJVB):

 Do you still get the setuid error and failure to connect to a session
 DBus? That's becoming hard to debug from a distance.

 The only thing you need to know about dbus is that clients find it via an
 environment variable that's easy to check for because its name starts with
 DBUS. I can confirm that dbus used to work just fine on 10.6 but it's been
 quite a while since I checked it.
 If you have Qt4 or Qt5 installed there's an application called qdbusviewer
 (probably in /opt/local/libexec/qt[45]/bin). If that starts and shows at
 least a few things that are not errors you're good on the dbus side of

 The fact you still get audio suggests that pulseaudio forks a process that
 does the actual work which doesn't crash.

 You are right that this might be a bug related to CoreAudio differences on
 10.6 . The exact reason for the crash here is that the CA module tries to
 free memory that was never allocated. You can try to debug that yourself
 (`lldb /opt/local/bin/pulseaudio` ...), you can wait for the port
 maintainer to jump in, or you can report the crash upstream.

 In case OpenDUNE is an X11 application: did you install pulseaudio with
 the +x11 variant? I take it you checked if it only supports pulseaudio?

Ticket URL: <https://trac.macports.org/ticket/46658#comment:20>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list