[MacPorts] #53065: QGIS @2.18.0 build failure

MacPorts noreply at macports.org
Tue Dec 20 02:29:06 CET 2016

#53065: QGIS @2.18.0 build failure
  Reporter:  BuddyVolly  |      Owner:  Veence
      Type:  defect      |     Status:  assigned
  Priority:  Normal      |  Milestone:
 Component:  ports       |    Version:  2.3.5
Resolution:              |   Keywords:
      Port:  QGIS        |

Comment (by EJFielding):

 I am getting the same build failure trying to update from QGIS @2.18.0
 which I have been using for a while to @

 I tried deactivating my qca @2.1.0_4 and activating qca @2.1.0_3+qt4
 (which required deactivating qgis and qca-ossl first). Then I tried to
 update qgis, but it still failed. MacPorts first reactivated qca-ossl
 @2.1.0_4, but then it seems to not find the correct qcaossl files.
 main.log excerpt:
 :info:configure -- Found QScintilla2:
 /opt/local/libexec/qt4/lib/libqscintilla2.dylib (2.9.3)
 :info:configure -- Found QCA: /opt/local/lib/libqca.dylib (2.1.0)
 :info:configure CMake Error at cmake/QCAMacros.cmake:64 (message):
 :info:configure   QCA OpenSSL plugin not found (run-time/unit-test
 :info:configure Call Stack (most recent call first):
 :info:configure   CMakeLists.txt:327 (FIND_QCAOSSL_PLUGIN_CPP)

 Is there another hint we can try?


Ticket URL: <https://trac.macports.org/ticket/53065#comment:5>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list