[MacPorts] #51402: Problem installing kmymoney on El Capitan

MacPorts noreply at macports.org
Sun May 15 10:51:54 PDT 2016

#51402: Problem installing kmymoney on El Capitan
 Reporter:  wlwood3@…  |      Owner:  macports-tickets@…
     Type:  defect     |     Status:  new
 Priority:  Normal     |  Milestone:
Component:  ports      |    Version:  2.3.4
 Keywords:             |       Port:
 I am trying to get kmymoney into a new installation of El Capitan on a
 MacBook Pro. Last fall, I was successful in getting this to work on a
 different new El Capitan installation on an iMac (and on everything else
 I've run it on--Linux, Windows and Mac--going back a number of years).

 Here's the problem I'm running into:

 I installed MacPorts and everything went fine. I then typed "sudo port
 install kmymoney4" and it told me it was computing dependencies. It listed
 all the dependencies and went for one (the first time out, this was gmp).
 It then listed a bunch of repositories where it looked and ended up with
 an error saying that archivefetch failed to find gmp, bringing the whole
 process to a halt.

 I tried this a few times, with the same result, so I thought I'd try just
 installing gmp individually. I typed "sudo port install gmp" and it worked
 perfectly. So then I tried kmymoney4 again, and ran into exactly the same
 problem with the curl-ca-bundle package. So I installed that separately,
 and it worked. I followed the same process (failed kmymoney4 install, then
 successful individual package install) with expat and libiconv, but
 kmymoney4 just keeps hanging on the next package.

 At some point, I got an error saying that my DNS server was reporting that
 some sites that don't exist actually do, and it suggested that I change my
 DNS server (this makes sense--my cable provider "helpfully" turns bad web
 addresses into a search that it takes command of). So I changed my DNS
 server to Google ( and and I no longer get that error.

 So it's clear that these packages are in the repositories, because they
 will install by themselves. But I can't seem to get them to install as
 part of kmymoney4.

 I'm hoping this is something dumb I'm doing on my end that someone much
 smarter than me will quickly realize. Any thoughts?

Ticket URL: <https://trac.macports.org/ticket/51402>
MacPorts <https://www.macports.org/>
Ports system for OS X

More information about the macports-tickets mailing list