[MacPorts] #54067: upc @ error: unknown type name 'isl_constraint'

MacPorts noreply at macports.org
Tue May 2 22:51:45 UTC 2017

#54067: upc @ error: unknown type name 'isl_constraint'
  Reporter:  caverac  |      Owner:  tenomoto
      Type:  defect   |     Status:  assigned
  Priority:  Normal   |  Milestone:
 Component:  ports    |    Version:
Resolution:           |   Keywords:
      Port:  upc      |

Comment (by caverac):

 Thanks for the detailed reply. I tried this

 fgrep -A 2 -B 2 isl `port file upc`

 And got

 depends_lib         port:gmp port:mpfr port:libiconv port:libmpc \
                     path:lib/pkgconfig/isl.pc:isl \
                     port:ld64 \
                     --with-mpfr=${prefix} \
                     --with-mpc=${prefix} \
                     --with-isl=${prefix} \
                     --disable-bootstrap \
                     --disable-multilib \


 Then changed in the dependencies to `isl14`. Actually wasn't sure about
 this, but also installed the port `isl14`. Didn't know how to change the
 path to `isl14`, because the include and the lib have different paths, but
 in the portfile, there's only one option `--with-isl`.

 After this, tried to download the `upc` again and this is what I get

 --->  Computing dependencies for upc
 --->  Fetching archive for upc
 --->  Attempting to fetch upc- from
 --->  Attempting to fetch upc- from
 --->  Attempting to fetch upc- from
 --->  Fetching distfiles for upc
 --->  Verifying checksums for upc
 --->  Extracting upc
 --->  Configuring upc
 --->  Building upc
 Error: Failed to build upc: command execution failed
 Error: See
 for details.
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 Error: Processing of port upc failed

 Same error as before. Should I try something else? Thanks!

Ticket URL: <https://trac.macports.org/ticket/54067#comment:6>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list