[MacPorts] #54101: Ports that depend on hdf5-18 should switch to hdf5

MacPorts noreply at macports.org
Tue May 23 22:28:31 UTC 2017


#54101: Ports that depend on hdf5-18 should switch to hdf5
-------------------------------------------------+-------------------------
  Reporter:  mf2k                                |      Owner:
      Type:  enhancement                         |     Status:  new
  Priority:  Normal                              |  Milestone:
 Component:  ports                               |    Version:
Resolution:                                      |   Keywords:
      Port:  h4h5tools hdfeos5 netcdf octave-    |
  devel py-tables ncarg                          |
-------------------------------------------------+-------------------------

Comment (by Dave-Allured):

 Replying to [comment:12 seanfarley]:

 Yes indeed.  Thanks for asking.

 Each package should be individually verified to be using
 `H5Pset_libver_bounds` so as to ensure writing backward compatible files,
 unless the relevant user community does not care.  This is particularly
 important for packages like Netcdf that are commonly used for public
 distribution of large volumes of HDF5-based files.

 This should be the responsibility of the original package developers, not
 MacPorts, IMO.  See, for example, what the Netcdf developers did:

 ‚Äčhttps://github.com/Unidata/netcdf-c/issues/250 (2016 April 7)

--
Ticket URL: <https://trac.macports.org/ticket/54101#comment:13>
MacPorts <https://www.macports.org/>
Ports system for macOS


More information about the macports-tickets mailing list