[MacPorts] #56086: build of db 48-4.8.30_4 fails in MacPorts 2.4.2 on macOS Sierra 10.12.6

MacPorts noreply at macports.org
Sun Mar 18 15:38:08 UTC 2018

#56086: build of db 48-4.8.30_4 fails in MacPorts 2.4.2 on macOS Sierra 10.12.6
  Reporter:  emsisson  |      Owner:  jmroot
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.4.2
Resolution:            |   Keywords:
      Port:  db48      |

Comment (by emsisson):

 Thank you for the quick reply; unfortunately, I had gone to bed for the

 I tried
 sudo port clean -all db48
 and redoing the install, but I saw the same result.

 Regarding whether previously-installed ports were binaries or from source,
 the earlier dependencies for the port I wanted (graphviz) appear to have
 been binaries. I looked at the saved output (from command script) of ports
 I installed earlier in the day, and most of them appear to have been
 binaries. However, two of them (wget, and its dependency gmp) appear to
 have been built from source because the saved output contains the
 following lines:
 --->  Configuring gmp

 --->  Building gmp

 --->  Configuring wget

 --->  Building wget

 I did use that install of wget to retrieve the files and then used openssl
 to verify them; that succeeded:
 $ cd ${HOME}/Downloads
 $ wget
 $ wget
 $ openssl dgst -ripemd160 -verify /opt/local/share/macports/macports-
 pubkey.pem -signature
 Verified OK

 I checked the page MisbehavingServers, and it suggests a problem with the
 ISP may be the cause. My ISP is a giant corporation, and I suspect that I
 will have little chance of suggesting that they reconfigure their DNS

 Since I have downloaded the files with wget, I will try building locally.

Ticket URL: <https://trac.macports.org/ticket/56086#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list