[MacPorts] #56169: QGIS 3 is very unresponsive after last update to 3.0.1

MacPorts noreply at macports.org
Wed Mar 28 05:33:02 UTC 2018

#56169: QGIS 3 is very unresponsive after last update to 3.0.1
 Reporter:  Malauch             |      Owner:
     Type:  defect              |     Status:  new
 Priority:  Normal              |  Milestone:
Component:  ports               |    Version:
 Keywords:  QGIS, unresponsive  |       Port:  qgis3
 There is one another problem with qgis3 port, which I found recently.
 After update to QGIS 3.0.1 (I made it ~10 minutes after committing to
 3.0.1 version to repositories), qgis started to by very sluggish and
 unresponsive. Scrolling through long layers list, renaming layers, adding
 new points are very lagging. In the same time official version (from
 Kyngchaos), which I installed on VM works really fast. I send two screen
 records with adding new points on both version.

 I tried to reactivate old version of Macports's qgis @3.0.0_2 but it was
 still slow and unresponsive. Therefore I think it could be something with
 dependencies (when upgrading to qgis 3.0.1 I made "upgrade outdated"
 command). I tried to reactivate some old versions dependencies but problem
 is still there.

Ticket URL: <https://trac.macports.org/ticket/56169>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list