[MacPorts] #57949: OpenVAS install fail

MacPorts noreply at macports.org
Wed Jan 23 16:35:06 UTC 2019

#57949: OpenVAS install fail
 Reporter:  miscMonkey  |      Owner:  (none)
     Type:  defect      |     Status:  new
 Priority:  Normal      |  Milestone:
Component:  ports       |    Version:
 Keywords:  openvas     |       Port:  openvas-server @2.0.3
 I tried to install in Mojave and El Capitan and the configuration fails in
 the same library.
 MacBook pro OS X El Capitan. version 10.11.6

 --->  Attempting to fetch openvas-libraries-2.0.4.tar.gz from
 --->  Verifying checksums for openvas-libraries
 --->  Extracting openvas-libraries
 --->  Applying patches to openvas-libraries
 --->  Configuring openvas-libraries
 Error: Failed to configure openvas-libraries, consult
 Error: Failed to configure openvas-libraries: configure failure: command
 execution failed
 Error: See
 libraries/main.log for details.
 Error: Follow https://guide.macports.org/#project.tickets to report a bug.
 Error: Processing of port openvas-server failed
 --->  Some of the ports you installed have notes:
   openldap has the following notes:
     A startup item has been generated that will aid in starting openldap
 with launchd. It is disabled by default. Execute the following command to
 start it, and
     to cause it to launch at startup:

         sudo port load openldap
   pinentry-mac has the following notes:
     If you previously didn't have pinentry or gpg-agent installed  and
 pinentry-mac has been installed as a dependency of gpg-agent,  you don't
 need to do
     anything to use pinentry-mac.

     If you want to switch to the GTK2, ncurses or Qt4 based pinentry
 program, please install pinentry with the correct use flags and  follow
 the instructions
     below substituting the pinentry-mac program  path with

     If you previously had pinentry and gpg-agent installed and would  like
 to switch to pinentry-mac, you will have to set  it as your pinentry
 program in

     Add the following line to the mentioned file:
     pinentry-program /Applications/MacPorts/pinentry-

     Be sure to comment previous "pinentry-program" lines, for example:

     pinentry-program SAMPLE


     #pinentry-program SAMPLE

     Afterwards, run
     killall -HUP gpg-agent

     or simply log out and back in again.

 I have tried several times, but nothing happens.

Ticket URL: <https://trac.macports.org/ticket/57949>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list