[MacPorts] #57964: could not execute xcode_select, no such file or directory

MacPorts noreply at macports.org
Sat Jan 26 13:04:57 UTC 2019

#57964: could not execute xcode_select, no such file or directory
 Reporter:  dzhub                                 |      Owner:  (none)
     Type:  defect                                |     Status:  new
 Priority:  Normal                                |  Milestone:
Component:  ports                                 |    Version:  2.5.4
 Keywords:  SDK, xcode_select, configure.sdkroot  |       Port:

 recently I tried to install some ports (for example git, wget, perl...),
 but every installation stopped and gave me this error:

 "Unable to determine location of a macOS SDK"

 I reinstalled Xcode 2.5, reinstalled the current version of MacPorts 2.5.4
 from the distribution package, but that did not help.

 Then I run

 sudo port diagnose
 Error: process_cmd failed: could not execute "xcode_select": no such file
 or directory.

 I cant find it in my Xcode installation.
 Was xcode_select introduced with a later Xcode version, and is not part of
 Xcode 2.5?

 I have tried some symlinking from the original Xcode directory
 (/Developer) to the directory that current Xcode versions use, but that
 did not help.

 What can I do, to define the SDK path in MacPorts?

 Thank you for any hints.

Ticket URL: <https://trac.macports.org/ticket/57964>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list