[MacPorts] #66422: failing to install gnuplot 5.4.3 apparently bc of llvm-3.7

MacPorts noreply at macports.org
Fri Dec 9 14:57:42 UTC 2022

#66422: failing to install gnuplot 5.4.3 apparently bc of llvm-3.7
  Reporter:  natelsonoptics  |      Owner:  (none)
      Type:  defect          |     Status:  new
  Priority:  Normal          |  Milestone:
 Component:  ports           |    Version:
Resolution:                  |   Keywords:
      Port:  gnuplot         |

Comment (by natelsonoptics):

 Thanks for taking a look, and apologies for the naive questions.

 I've attached the output of {{{sudo port -v installed}}}.

 This is not a migration; while I did migrate from a timemachine backup
 onto the M2 machine, I had never installed ports before.

 I initially tried following the simple installation instructions; after
 that failed, I looked at the list of tickets and followed this approach:
 sudo port clean gnuplot
 sudo port selfupdate
 sudo port upgrade outdated
 sudo port install gnuplot
 After iterating that a couple of times, which cleaned up almost
 everything, now when I run
 sudo port -v install gnuplot
 I get this:
 --->  Computing dependencies for gnuplot.
 --->  Cleaning gnuplot
 --->  Removing work directory for gnuplot
 --->  Scanning binaries for linking errors
 Could not open /opt/local/lib/libffi.6.dylib: Error opening or reading
 file (referenced from /opt/local/libexec/llvm-3.7/bin/FileCheck)
 --->  Found 160 broken files, matching files to ports
 --->  Found 1 broken port, determining rebuild order
 You can always run 'port rev-upgrade' again to fix errors.
 The following ports will be rebuilt: llvm-3.7 @3.7.1
 Continue? [Y/n]:

Ticket URL: <https://trac.macports.org/ticket/66422#comment:4>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list