[MacPorts] #66549: qt511-qtimageformats @5.11.3_2: Could not resolve SDK Path for 'macosx10.11' using --show-sdk-path

MacPorts noreply at macports.org
Wed Dec 28 09:44:13 UTC 2022

#66549: qt511-qtimageformats @5.11.3_2: Could not resolve SDK Path for
'macosx10.11' using --show-sdk-path
  Reporter:  thetrial              |      Owner:  MarcusCalhoun-Lopez
      Type:  defect                |     Status:  assigned
  Priority:  Normal                |  Milestone:
 Component:  ports                 |    Version:  2.8.0
Resolution:                        |   Keywords:  elcapitan legacy-os
      Port:  qt511-qtimageformats  |

Comment (by thetrial):

 I tried to symlink this sdk into the two locations, namely to a homonymous
 folder – but that did not work. I’m not sure how the mechanism of --show-
 sdk-path works. Perhaps not with simple detection but with switches
 somewhere in a plist.

 If MacPorts offers to install additional sdks it would be nie if there was
 a postflight script, adding the necessary elements to use these sdks when
 they are needed.

 I’m really not sure if I should not give up the adequate macOS el capitan
 xcode 8.2.1, get rid of it and install xcode 7.3. This would be a strange
 and maybe big step, but these problems are annoying. Though it worked
 until this last stumble. But but my revbump hangs.

Ticket URL: <https://trac.macports.org/ticket/66549#comment:17>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list