[MacPorts] #66332: R @4.2.2_1: error when trying to install.packages possibly due to port/rpath configuration

MacPorts noreply at macports.org
Wed Nov 23 09:20:43 UTC 2022

#66332: R @4.2.2_1: error when trying to install.packages possibly due to
port/rpath configuration
 Reporter:  MarcKaufmann  |      Owner:  (none)
     Type:  defect        |     Status:  new
 Priority:  Normal        |  Milestone:
Component:  ports         |    Version:
 Keywords:                |       Port:  R
 I installed the R port, where I had to follow instructions in ticket
 #66095, after which it worked. The first thing I did was try to install
 the tidyverse package, which failed due to the package fs not installing.
 Here is the part of the logs where it hits the error, full logs are

   CC       src/unix/libuv_la-random-getentropy.lo
   CCLD     libuv.la
 ld: warning: argument missing after -rpath
 ld: can't map file, errno=22 file '/opt/local/lib/libgcc' for architecture
 clang: error: linker command failed with exit code 1 (use -v to see
 make[1]: *** [libuv.la] Error 1
 make: *** [libuv-1.38.1/.libs/libuv.a] Error 2
 ERROR: compilation failed for package ‘fs’

 I talked with someone on the R irc who said that this looked like an issue
 they hit (some years ago, I think) with MacPorts installation of R. They
 pointed me at the following Stackoverflow question:

 I tried to export the environment variables for CPATH and
 CPLUS_INCLUDE_PATH, then run an interactive R session and install the
 package, but nothing changed. I do not know where to set the other
 variables mentioned in that StackOverflow post, nor if that's what's going

 I understand that this may not be an issue with MacPorts, but it seems to
 be a configuration issue with paths, so it may be. Even if not, I'd
 appreciate some help on where to look next or whom to ask.

Ticket URL: <https://trac.macports.org/ticket/66332>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list