[MacPorts] #65921: gtk2 +quartz install and configuration failed on mac os x 10.9.5

MacPorts noreply at macports.org
Mon Oct 3 18:03:53 UTC 2022

#65921: gtk2 +quartz install and configuration failed on mac os x 10.9.5
  Reporter:  yannlr37  |      Owner:  mascguy
      Type:  defect    |     Status:  assigned
  Priority:  Normal    |  Milestone:
 Component:  ports     |    Version:  2.7.2
Resolution:            |   Keywords:  quartz
      Port:  gtk2      |

Comment (by yannlr37):


 Finally I found a way out. A hard solution, but it worked :)

 You were right, something went wrong with my build tools. I think this was
 related to a bad xcode install (wrong version of clang, enable to build
 glib2, then gtk2)

 After a fresh install of Mavericks (I had no choice), I tried to re-
 install gtk2.
 Here is the steps a followed :

 1. re-install MacPort (v 2.7.1)
 2. re-install Xcode (v 6.1.1)
 3. install Command Line Tools then GTK2 (with Quartz option) :

 xcode-select --install
 sudo port install xorg-server-legacy
 sudo port install gtk2 +quartz
 sudo port install gtk-osx-application-gtk2

 4. I install a theme switcher to give an old Aqua look

 sudo port install gtk-theme-switch

 And, yes, it works now.

 Again, thank you for you time and your help.
 I hope this will help someone else because it's quite hard to find useful
 infos about old OS.

Ticket URL: <https://trac.macports.org/ticket/65921#comment:19>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list