[MacPorts] #66032: MacPorts 2.8.0 errors on upgrade

MacPorts noreply at macports.org
Thu Oct 20 13:23:59 UTC 2022

#66032: MacPorts 2.8.0 errors on upgrade
  Reporter:  lukaso  |      Owner:  (none)
      Type:  defect  |     Status:  new
  Priority:  Normal  |  Milestone:
 Component:  base    |    Version:  2.8.0
Resolution:          |   Keywords:
      Port:          |

Comment (by gmpalter):

 I saw the same error on the first selfupdate but the second worked without

 I wonder if this is a problem with the group, not owner,  of
 and .../ports. On my machine after the selfupdate, the group ID is 505
 but, on my system, the group ID for macports is 501.

 I corrected the group on those directories using "sudo chgrp -R macports".

 I then did another selfupdate and the group ID was change to 505.

 Finally, I changed the group ID back to macports and tried running the
 installer instead. After I did, the group ID had been changed back to 505.

 For the record, there is no group with ID 505 on my system.

Ticket URL: <https://trac.macports.org/ticket/66032#comment:2>
MacPorts <https://www.macports.org/>
Ports system for macOS

More information about the macports-tickets mailing list